var blah = GetBlah();
if(blah != null)
//Do Stuff With blah
I want to say
if((var blah = GetBlah()) != null)
//Do stuff with blah
I'm not sure why the extra line bothers me - possibly because it's a pattern I keep having to repeat in my code, and any pattern I repeat irks me after a while. That's why computers are there, to stop you having to do the same thing over and over again.
Original post on Dreamwidth - there are comments there.